ISLOG Logon (Windows NFC Login)

  • @jasok2 Thanks for the logs.
    It looks like it is incomplete, did you truncated it at the beginning or forgot to restart ISLOGService service?
    Otherwise maybe your reader just disappears for an unknown reason, you could also give a try with ReadCard analyze tool community version which is using the same RFID/NFC middleware (LibLogicalAccess). If your reader / tag disappears on ReadCard after a while, then the issue is on the middleware or the reader.
    Thank you.

  • Small update that remove 'beep' on logon, and add data encryption on nfc tag.
    Stored nfc text record is now AES-128 encrypted with a random key generated at first tag use, XORed with tag UID, and base64 encoded for convenience purpose.

    No changes about @jasok2 current issue.

    You can download it here :
    64-bit: Logon NFC Community-4.7.0713-x64.exe
    32-bit: Logon NFC Community-4.7.0713-x86.exe

  • @Maxime-C. said in ISLOG Logon (Windows NFC Login):

    aybe your reader just disappears for an unknown reason, you could also give a

    I didn't truncate it, that was the entire text. and the file didn't even appear until after i restarted the service.

  • @Maxime-C.

    thanks @Maxime-C the encrypted text works great :) I still get the beep at logon.

    edit- I dont get the beep at logon, I get it at unlocking the computer if its already logged in and locked.

  • @Lokki said in ISLOG Logon (Windows NFC Login):

    Yeah, that's what I was getting for a start. I manually logged in a few times, then rebooted for something else and at some point it's started working properly.

    OK so I seem to have had the same experience as you @Lokki of the issue just going away after a while, tonight since installing the updated software I have not had the issue again. I think we need to just keep an eye on it because @Maxime-C says that no fix was put in the new file for this.

    I will report back with a new set of logs if this happens again.

    EDIT- another thing iv noticed is that the login and unlock does take a good two seconds or so, perhaps at first @Lokki and I just wasn't waiting long enough....

  • Ok, good to know everything is working properly now.
    I also believe this could come from the fact you didn't waited long enough before removing the ring from the reader. It is safe to keep it around 1sec on the reader.
    I will wait for more feedback and provide an official release with dedicated web page. Thanks for your tests!

  • Community Helper

    @jasok2 said in ISLOG Logon (Windows NFC Login):

    EDIT- another thing iv noticed is that the login and unlock does take a good two seconds or so, perhaps at first @Lokki and I just wasn't waiting long enough....

    @Maxime-C Negative... while it was playing up I tried for up to 1 minute of the ACR122 reading the ring (green light) without the computer successfully logging in. Also, the option to manually log in simply was not there which forced me to reboot.

    Anyhow, that's resolved itself now. I'm using the new version and experience the beep as per @jasok2 's post - no beep at initial logon, beep thereafter.

  • Ok... well we will see if this is happening again to someone and investigate further at this moment.

    I created a webpage for the solution to have an unique place where to get latest version, see

    Please feel free to suggest anything else if you believe it is missing. I hope you enjoy it otherwise ;)

  • Hi guys I have a weird one. Ever since ISLOG Logon (Windows NFC Login)

    Every time I touch my ring to the phone either to login or otherwise the fitbit app on my nexus phone opens. If I uninstall the fitbit app, then it stops, but starts again if i reinstall the fitbit app.

    Erasing my card makes the problem go away, but then i cannot login to windows using the ring.

    Has anyone seen anything like this before? even with a different app?

    just reaffirming the issue is on the android phone, not on windows, but removing the windows logon information on the ring makes the phone behave properly.

    Cheers Jason

    @Maxime-C , @Lokki

  • Community Helper

    Huh, that's interesting.I haven't experienced that one.
    Though occasionally it does seem like the unlock system doesn't quite go all the way and the screens will stay blank or on the lock screen until I mouse-click. Then the desktop pops up and all is good.
    I'm assuming that's an issue with windows just plain being odd.

  • Its 100% reproducible, The text file that ISLOG puts on my ring tag somehow makes my phone open the FitBit app.

    Logically in my mind this is impossible!!

    @Maxime-C any ideas ?

  • @jasok2 this is weird and not excepted. What the text record written by ISLOG Logon looks like? Any chance you can copy/past here (if you're using a test password, otherwise try to change it to a test password and confirm this is still happening)? Thank you.

  • @Maxime-C here is the record. for now I'm dealing with the issue by writing the login onto the other side of the ring and twisting it around when i want to login to my computer compared to logging into my phone.

    Its a really weird one. I can only guess that maybe the text string is somehow the same or similar enough to the FITBIT app ID and it gets launched, or something else weird and coincidental.

    alt text

  • silly question...which nfc readers are recommended for this?

  • Community Helper

    I've personally tested the ARC-122U, OMNIKEY 5021CL and OMNIKEY 6321. Different sizes and shapes but they all work well.

  • on order now, will check it out and play next week....see how it goes with domain setups

  • question for developers?
    what OS/setups have been tested so far?
    i have
    x64/86 win 7
    x64 win 10
    all off and on domain services?
    what would be usefull to have tested?

  • Thanks @jasok2. There is nothing specific on your data. I don't know well how FITBIT works but maybe they try to do something as soon there is a text record on the tag?

    The solution is tested on Windows 7, 8, 8.1 and 10. Works on any edition (family, professional...)
    The commercial version is used on few tablets by customers but this NFC community version should works on it too.
    Only local accounts are supported for NFC Community edition, this is a restriction on the community version to ensure it is used for personal use. If you want to use a domain the commercial version is required (but it can be discussed, we had to start from somewhere ^^).

  • comepletely understand......what sort of pricing is available on the comercial version? we are about to start alot with NFC...and this seems like a likely scenario...there are a few people with rings, would be awesome if long term we could organise something with mclear for the hospital

  • @MarkGabb thanks for asking. I don't want to be too commercial here as this thread is about the community version so I will keep it short. NFC community version apart, there is a standalone version and a client / server version. Pricing is per user or per workstation depending what is cheaper for the customer. Additional one-time cost for the server. Until now our main business was in France and border countries for this product line. Hospitals are indeed a good part of our market (with a card today, not a ring). We generally provide installation and support services to complete a project successfully. I believe there is such opportunities on other countries too. I'm not sure about the ring here, some establishments ask caregivers to remove their jewelry before to start working.