Ring unlock app not appearing when I unlock my phone



  • Hi everyone,

    I'm looking for a bit of help, please!

    Summary
    I recently tried to set up the Ring Unlock app on my phone. While the NFC ring is recogised as it should be, the app does not display when I unlock my phone. I am not prompted to use the ring to unlock my phone.

    Version Info
    I believe I have the most recent version of the NFCRing – the black ‘Horizon’ model. My phone is a

    • Huawei GRA-L09
    • Android 5.0.1,
    • EMUI version 3.1,
    • Custom version CUSTC432D001
    • The phone is not rooted.

    This has the following apps installed:

    • co.mclear.nfcringunlockpro 1.6.2.
    • NFC Ring Control 0.3.04

    Settings / What I Did:
    Initially, I used the ring control app to register and gain a code for the ring unlock app. As far as I am aware, this was successful. I also set up my ring with the ring unlock app, and changed some settings.

    1. Open the Ring unlock app
    2. Touch the ring to the phone
    3. – I see the NFC Ring Unlock Settings page
    4. Choose Unlock Settings > my settings are
      ** Use with no lockscreen = No
      ** Unlock Delay Type = Timeout
      ** Unlock Count = disabled
      ** Unlock Timeout = 5 minutes
      ** Failed Unlock Count = disabled
      ** Manage Device Administrator = not disabled
      ** Disable lockscreen features = No
      ** Manage Call behaviour = Unchanged, all default.
    5. I have left all settings in ‘Lockscreen Customization’ and ‘Other Settings’ as the defaults (unchanged).
    6. Exit the application by pressing ‘back’.
    7. Wait for 5 minutes
    8. Press the power button to turn the screen on

    Behaviour
    I see the Huawei/Android unlock screen and am prompted to enter my pattern. I can then access all of the apps on my phone as usual. This is also the case if I manually lock my phone by pressing the power button.

    Expected
    I’d expect to see the ring unlock screen after my phone is locked. Does anyone know why this is not happening? Any help would be very much appreciated, and I’m more than happy to provide more information if necessary.



  • If you're on 5.0.1 or higher, you can use the native Smart Lock (turn it on in Settings -> Security -> Advanced -> Trust Agents, then it will appear in Security -> Smart Lock) instead of the NFC Ring Unlock app.


  • Community Helper

    Using the integrated version is actually recommended as it provides more security.



  • @Lafunamor
    If it works. Otherwise it provides the ultimate security by not accepting your nfc credential.
    For the people who have that android bug, is there a solution to the OP's problem?



  • @Tails
    Mine worked better after I got rid of the android lock screen. If you're on Marshmallow then you might also no longer have the "No Lock" option anymore and I had to set mine to "Swipe" and then use https://play.google.com/store/apps/details?id=com.jusckeux.nolockscreen&hl=en to remove that.

    According to Google support, "No lock" is no longer going to be an option. No idea if that is true but it is definitely missing from my phone now on 6.0.1. If you already had it set to that you seem to get to keep it, but I enabled the smartlock, which didnt work, and was not able to go back to "No Lock".

    In the "NFC Ring Unlock Pro" app, in "unlock settings" at the very top right (in the title bar" does it say "enabled"? if it says "disabled", hit that (it's a button). Otherwise i'm not sure what else to suggest right now.


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.