@Tails Mine worked better after I got rid of the android lock screen. If you're on Marshmallow then you might also no longer have the "No Lock" option anymore and I had to set mine to "Swipe" and then use https://play.google.com/store/apps/details?id=com.jusckeux.nolockscreen&hl=en to remove that. According to Google support, "No lock" is no longer going to be an option. No idea if that is true but it is definitely missing from my phone now on 6.0.1. If you already had it set to that you seem to get to keep it, but I enabled the smartlock, which didnt work, and was not able to go back to "No Lock". In the "NFC Ring Unlock Pro" app, in "unlock settings" at the very top right (in the title bar" does it say "enabled"? if it says "disabled", hit that (it's a button). Otherwise i'm not sure what else to suggest right now.