Control app freezes on startup



  • The control app is unusable on my Samsung Galaxy Axiom / Ice Cream Sandwich phone. The first page loads with 5 options, but none of the buttons can be clicked because it's frozen, then it crashes and closes a few seconds later.

    Is there anything I can do to get this thing working??


  • NFC Ring Team

    Hey guys, I haven't seen this before on any devices with our app ;\

    Brett.

    1. Is the phone running any custom or settings?
    2. Please download NXP TagInfo, does that work okay with your phone/ring?

    Team:

    • The Android device does have NFC Hardware
    • I can't see any reports of Axiom having issues with phonegap apps


  • No custom settings, I did make sure NFC was turned on.

    NXP TagInfo installed and ran no problem. I can't get it to scan the ring though. I tried both sides of the ring, and tapped it all over the phone.


  • NFC Ring Team

    Hrm, something is very odd here. Did you get some stickers with your ring that you can test things with? They are an optional purchase and will tell us if NFC is working properly on your device.

    I haven't heard of anyone trying the Axiom before so I don't know if this is a device issue or an app issue or what yet ;\



  • @johnyma22 the ring came with four very tiny circular stickers, I don't think those are what you're talking about though. I didn't pay extra NFC stickers.

    The way I see it, from a troubleshooting perspective:

    • The control app definitely has problems supporting my phone. There's no other reason that it would be so unusable.
    • The ring MAY have an issue, since the other NFC app you suggested cannot detect it
    • Alternatively, the phone's NFC functionality MAY have issues.

    On the ring vs the phone's NFC, we won't know for sure unless I can either:

    • get another NFC tag to test with
    • get another NFC device

    Since I've already spend money on this phone, I don't feel inclined to purchase another one simply for troubleshooting.

    I would like to ask that NFC Ring do one of two things:

    • give me a refund for the ring
    • send me some other NFC tag to continue testing with, that would help us get closer to the real issue.

    I was a big fan of the tech, but right now I have to conclude that both the ring and app are not functional. I believe that merits a refund. And if you'd like to tack on another $30 to the refund, I'd be happy to ship the ring and the Samsung Galaxy Axiom back to you, so you can further improve your hardware and software support.

    Please let me know thanks.


  • NFC Ring Team

    I emailed you a code so you can get some free stickers from us so we can isolate where the problem is.

    You are fully entitled to a refund should you want one, that's not a problem at all http://nfcring.com/returns has the returns policy and you are fully covered by that so don't worry.

    We won't let you down and will do everything we can to get this right.



  • Im having the same exact issue, the app opens up, but im unable to click anything at all. Im not really interested in the control app that much except for the fact that I have to use it to register my ring, so I can use the unlock app. (which seems to work fine).

    @johnyma22 Is there any other way I can register the ring, and get a user/pass to use the unlock app? I can provide any information you need to prove I did purchase a ring directly from your site.

    Edit: i just tried installing the app on a second phone, and have the same issue.


  • Community Helper

    what phones and Android versions are you using?



  • Galaxy note 2(android 4.1.2) and galaxy s2 skyrocket(dont remember the version)


  • NFC Ring Team

    Okay what the deuce.. I'm going to guess it's an android 4.1.2 issue, I will see if I can find a device running 4.1.2 to debug with!


  • NFC Ring Team

    I pushed a new app up for beta testers.

    @nineteeneleven can you try it out to see if it works?

    You will need to sign up to beta testers program to get access to it.

    Let us know :)


  • Community Helper

    @nineteeneleven @Brett do you have any "ad blocker" app installed? We had issues with such apps blocking content of our apps


  • NFC Ring Team

    I pushed another new app for beta testers.


  • Community Helper

    Something else to consider - @Brett's Axiom is a CDMA version of a GS3 mini, basically. It's got the same low power NFC circuitry in it, with the same poorly matched large antenna. This wont be helping things at all where reading a ring is concerned.


  • NFC Ring Team

    Brett updated his support ticket stating NFC on device does not appear to be working. I have asked him to update us further here and to continue the conversation here.



  • I've got the same issue with my Motorola razr I running Android 4.1.2


  • NFC Ring Team

    @Julian185 Any idea on the cause? Do you have any adblocker software installed etc?

    Thanks for sharing!



  • No adblocker, security software etc installed. The nfc ring unlock app is running perfect till it need to log in, but for this i need the control app.
    maybe it isn't working because of the Intel CPU which has problems with some other apps



  • I'm having the same issue with my Samsung Note II, Android 4.1.2 The unlock App works fine but can not get the control App to work... I click on the options but nothing happens. Phone does not lock up. So I am not able to register to use the unlock app. I was reading there is a beta app to download but do not see where to get that app. any help would be appreciated. Also, I do have the NFC on and have written to tags and they work.


  • NFC Ring Team

    Beta app is at same point as production app..

    Do you have the latest version of the control app?


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.