NFCring unlock app problem

  • Dear NFC ring team,

    First of all, sorry for my bad english, I am french so my english is pretty bad.

    So; I received my NFC ring today but I've got a problem with the nfcring unlock app.

    When I get the screen to enter my email and password; I always get a screen "password or email is not recognized".
    The first time I got it, I tried to reset my password. But even if I change my password, it's always the same problem. I never can use the settings or the other functions..

    Why this problem occurs and persists ?
    Because of it I can't use the app settings.

    Thanks for your help~

  • Community Helper

    did you use this link to reset your password/verification code?

  • Community Helper

    Hi @frenchihoya first you'll need to install the NFC Ring Control App, register your ring and then enable the unlock app. If you have any issues doing that, let us know.

  • Hello~

    Unfortunately, I already registered with the NFC Ring Control App, but the problem is the same. I tried the link to reset my password but when I entered my new password the app said "Your username and/or password has not been recognized".
    I tried with an other mail but it's still the same problem.
    I don't understand...

  • Community Helper

    please make sure you're entering the email address correctly. I believe the fields are both case sensitive.

  • I'm sufffering exactly the exact same issue. I have registered the ring through the control app. But when I get to verify element of the ring the password email combination is never correct. I've double checked the email address is correct and even tried case sensitive permutations. I've reset the password each time and nothing updates. Yes my phone is connected to the internet ;-)

    If I go back to the control app to try and register it tells me that the ring is already registered and asks me if I want to change my password.

    I'm going round and round and round... but to be honest just think there is a bug somewhere

  • Community Helper

    hmm... there shouldn't be a problem. maybe @johnyma22 has an idea?

  • @Kris - have you updated the NFC Ring Control app to the latest version from the Play store?
    If you have done so and are still getting the issues - shoot us an email to with the email address you are trying to register and i'll check it out for you. We did identify an issue with the way data way being saved in our database, but made some changes a good few weeks ago now that should have solved the issue.