Won a ring - phone doesn't recognize it

  • I apologize if this is a n00b question, but:

    I won a free NFC ring. When I hold it to my phone (a Nexus 5), nothing happens.
    NFC on the phone is working: I can tap-to-pay, other NFC tags I own work, and the extra NFC tag that came with the ring is recognized by my phone as a blank tag.

    I did not receive an unlock code with the ring. I see that there is an "NFC Ring Unlock" app, but with no code, I can't use it.

    So...do I need a code? Did I get a bad ring? Or am I completely missing some step I need to do?


  • Community Helper

    Hi there, is it one of John's NFC Rings or is it another one like GalaRing?
    The Nexus 5 is slightly picky on where it reads, there's a thread with 'sweet spot' pictures that you should check. It may help increase your chances of getting a good read.

  • It's an NFC Ring. With your help, the phone is now recognizing it - thanks!

    I'm still curious about the verification code issue, though. To clarify, I launch the NFCRing unlock app, and the screen says:

    NFC Ring One Time Verification
    Email: ___
    Verification Code: ___

    I tried putting my email but leaving the verification code blank, but then clicking the button just takes me to the NFCRing site. I'm a bit confused on how/where to get the code.


  • Community Helper

    You definitely need that verification code in order to be able to use it. Are you able to contact the person you won it from?
    If you set NFC to on then the phone should automatically read the tags when they're in the right place yeah? That's how the Nexus 5 I was playing with worked anyway.
    So if you do that then you'll be able to move the ring around the back of the phone until you hear the read successful/unsuccessful noises.
    Holding the phone upright (portrait) orient the ring horizontal and try from center bottom moving upwards, that should do it.
    If you have too much trouble there's a sweet spot picture available for Nexus 5.

  • NFC Ring Team

    Has this been sorted or do you still need help setting it up?