Error: Tag is Invalid Issue



  • I received my replacement Eclipse ring on Saturday this past weekend. I downloaded the NFC Control App that the ring had for start up. Upon creating an arbitrary text on the secure side of the ring, the app went through the motions of creating and tapping again to see if it works I got the pop-up toast that says ERROR: TAG IS INVALID. Reaching out to support, I was instructed to join the forum and search for a resolve. I searched and only found 1 topic from 6 months ago and tried the apps mentioned in it to fix the problem with no success. Did anyone here have the same issue and get their NFC ring fixed? Here is the forum topic I mentioned above: https://forum.nfcring.com/topic/705/error-tag-is-invalid


  • Community Helper

    Basically public/private is pretty arbitrary, so both tags are exactly the same - are you able to read+write to the other tag properly?
    Are you able to try a different app on your device and possibly a different device, just to narrow things down a bit?



  • @Lokki I am able to read+write to the public side with no issues. The private side is the one where I can use to unlock my phone but every time it unlocks the pop-up toast shows up with the error. I have tried just about every app that has erase memory, erase tag & format tag. It always has the same error to read+write. I have also got co-workers to try out my ring and every device has the same error. TAG IS INVALID. What should I do next? I just got this on Saturday.


  • Community Helper

    What method are you using to unlock the phone? The NFC Ring Unlock App or the built in trusted devices setup?



  • @Lokki I'm using the native smart lock as I did before on my last ring. Had no issues and was able to read and write until my ring broken in 2 pieces and got this replacement ring. The NFC ring unlock app I tried but doesn't recognize tag.


  • Community Helper

    Ah, right! Cool - give this a try and see if both tags show up the same: https://play.google.com/store/apps/details?id=com.nxp.taginfolite&hl=en



  • @Lokki Ok, I got home and downloaded the app you linked. Seems that the app does read both tags and displays the information on them. Is this good news? What next?


  • Community Helper

    @Luiscortes77 sorry for the delay, weekends are long and busy in tourist destinations!
    So when you read both tags did both turn up as expected, NTAG216 etcetera?



  • @Lokki yes they both did.


  • Community Helper

    Sorry, I've just noticed I'm going to need to re-flash my tablet so I can try and duplicate what I think has happened. Bear with me for a moment.



  • @Lokki No problem.


  • Community Helper

    Hokay. Hooray for completely discharging a battery by accident!

    I've just soft locked and permanently locked a tag and gone through each option to return it to normal to verify it all works properly with an NTAG216.

    So, if you could download NXP TagWriter, and see if you can use it in the "erase tags" mode. It will give you either a successful result or return "This tag can't be erased" plus a reason.
    If that happens, try format all data while working your way up to "Factory Default" as the last attempt.

    I get that you've tried all this, but just run through it again once more for me, and then if it's a complete failure get back to support@nfcring.com and let them know we've walked through all the possibilities here and you need an RMA.



  • I just received 2 replacement rings and when using the unlock app on 2 different devices it had a problem reading 1 inlay on each ring. After trying a few things I erased the nonworking inlays and redid the procedure and has been working fine since then.


  • Community Helper

    That's great, glad to hear you're all sorted, @Je-Remy-Peters !
    Hopefully we hear back from @Luiscortes77 in the same vein soon!


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.