Unlock not working for ANY 2016 KS rings



  • This issue has been brought up numerous times in the KS comments but are not getting any responses there, so I figured I would post here. Setting up the unlocker app works fine, but then after opening the app again it asks for verification, then displays a username/password error. Even after creating an account myself on the website, it gives this error when trying to reset the password in the app:
    "{
    "code": 205,
    "error": "no user found with email solongsidekick@gmail.com"
    }"

    Seems pretty obvious that zero thought went into making sure that people who didn't buy the rings on this website would be able to use the app properly. This is the main reason I backed this project, please advise.

    Oh also, the unlocker doesn't ever actually show up when I turn my screen on. I can get the screen to pop up when opening the app manually, but that's it.

    Stock unlocked AT&T LG G4



  • @SoLongSidekick Do you know what version of android that is running ? I think from 5 onwards you can use "trusted devices" its in the settings security section on your phone.

    Its a far superior experience to unlock your phone than the unlock app because its built into the operating system by google.

    I know this doesn't really help if that's not an option on your phone but if it is I highly recommend it.



  • Yeah that's the system I'm using now, and will probably just stick with.although I don't particularly like it. I was mainly posting this so once the KS backers find their way over here there will hopefully be an answer for them.


  • Community Helper

    Ok, this looks like a misunderstanding here - it's expected that a new user who wants to use the NFC Ring Unlock App will also install the NFC Ring Control App.
    The Control App has a "Register" button in it, this registers your ring with your email address at which point you enter the password you'd like to use.
    Once this has happened you can then Register the Unlock App and use it.



  • I installed the ring control app, registered the ring, then I installed the unlocker app. Every time I unlock it asks me for a one time verification and every time it says my username or password are wrong or do not exist. I found after resetting my password a couple times that the email address is case sensitive (dumb) but even once I've reset the password and verified that it is being entered correctly, it still says that the username or password are incorrect.
    The code 205 error above for me is caused by the fact that my phone autofilled my email with a capital letter at the beginning in registration app (keyboard just saw a text field) but with a lower case in the unlock app (keyboard saw an email field). Since the username is case sensitive, this caused it to say the username did not exist.
    The password in the unlocker app is entered in a totally unprotected text field, so not only does the text show, but my phone tries to autofill and after I've entered it my phone will then suggest my password in other fields unless I go in and delete it. That is also a problem.
    All of this along with the fact that the unlock login is completely separate than the NFC ring and forum login, which is inconvenient. I do understand that sometimes you need two separate services if you can't build your own so this is understandable but no less annoying.
    So I'd agree with the original poster that Unlock is simply not working. I trust you'll get this fixed soon.
    Thank you.


  • Community Helper

    Hi, you can add issues etc to the github - https://github.com/mclear/Android_NFC_Ring_Unlock/issues



  • Uh seeing as the vast majority of people have never used a Git repo before I don't think it's the customer's responsibility to add issues to the repo. This is well known at this point seeing as 100% of their newest customers are having this issue. This should be their top priority as it was one of the most advertised features of the ring..


  • Community Helper

    @SoLongSidekick - I think "100%" is probably one of those over-estimation things. The point of feedback going to the github repo is that then you have exactly the people who are having problems, reporting them and describing exactly their setup/hardware/firmware.

    I'm not saying it's the responsibility of the customer to go out of their way and do an internet thing on the internet, but it does help to get things fixed faster and more effectively for those who are affected.



  • Just thought I'd say that as a new owner of an Horizon ring, I've not installed any of the NFC Ring apps as Android's NFC trusted device option works really well.



  • @Cie said:

    Just thought I'd say that as a new owner of an Horizon ring, I've not installed any of the NFC Ring apps as Android's NFC trusted device option works really well.

    I'll be curious if it just stops working for you at some point. On my Nexus5 it would work for a few hours then randomly stop until I went and disabled then re-enabled it. There is a bug open with google for it.



  • Same with me on a stock Note 3, on EE with 2013 rings, Not tried my 2016 ones yet.



  • For the first time this morning my ring wouldn't unlock my Nexu6 with Android 6.0.1. After numerous attempts to get the phone to unlock, and after checking the the sensor was working I simply re-cycled the sensor on my phone and since then it's been lightening fast to unlock.



  • @Cie
    I think it is a feature the the smart lock disables itself after 4 hours or non-use or something? There were some people saying that the location unlock would still lock their phone after it had been idle for 4 hours. Maybe this was just that case?

    With my Nexus 5 it'd be working fine, I'd be using my phone to control my media center (unlocking it every 10 - 30 mins) and then randomly it'd stop and unlocking the phone with the pattern then letting it lock again still wouldn't read the nfc. Restarting the phone or disabling / enabling the smart lock would fix it again for a while. Also on 6.0.1.



  • The only place I've seen the 4-hour time limit documented is this help article from Google: https://support.google.com/android/answer/6093922?p=personal_unlocking&rd=1
    My Nexus 5 always refuses to unlock with NFC Smart Lock every morning (after 5-8 hours idle). After unlocking it once by hand (by drawing the pattern), NFC unlocking works again.

    The bug is a different issue - it happens at random, whether or not the device has been idle for > 4 hours, and the affected users need to toggle NFC, Smart Lock, or restart in order to have NFC unlock working again.



  • Yes.
    I just wanted to clarify that there was a 4 hour timeout as well.
    Mine never worked for 4 hours so I had the bug rather than the timeout.


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.