Unable to register ring.



  • I have recently received my new 2016 ring, which looks amazing. This is the second NFC ring I have bought and they are fantastic. The rings work fine and I know where the sweet spots are on the phone. The problem is with the NFC apps. The NFC ring control app refuses to see the ring. When I am in the register section, I can hear the 'bluetooth succes' noise that android makes, there's no error pop up that I get from rushing a connection, but the app does nothing, doesn't register the ring. So if I can't register the ring then I can't use the NFC ring unlock app. I bought the ring to be able to unlock my phone, if I can't use the unlock app then it's useless and I want to send it back.
    I am using a rooted Z1 compact, with a 4.4. build.
    Exactly the same thing happened with the first NFC ring I bought and it was only fixed by support@nfcring.com setting me a verification password.
    Thanks in advance for any advice on how to resolve this.


  • Community Helper

    There is no need to register your ring again if you've already done it one. Just open the unlock app and login using your email and password (that worked before). Register your ring as 'key' and you're done.



  • Unfortunately I uninstalled the unlock app after I lost my first NFC ring. So I have downloaded a new version with my new ring. I did dig through my emails and found the login sent to me by support@nfcring.com, but that didn't work. So I have an unlock app that I can't verify.


  • Community Helper

    just reset your password using this link:
    https://me.nfcring.com/validationCodeReset

    Please note that e-mail address and password are casesensitive



  • Thanks, that link fixed it. All working now.


  • Community Helper

    awesome! Enjoy


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.