My experience with the NFC Ring



  • It has been pretty poor. Receiving the ring, I was able to make it a trusted device without downloading any of the software, and it has worked maybe 20% of the time. Doesn't read most of the time. When it does, yay, but often it's annoyingly undetected, or there's some other OS criteria that prevents the ring from unlocking my phone, so I have to use my password. It also brought up a "adding new nfc tag" alert constantly, after the phone is unlocked.

    Wondering if the software would help, I typed "NFC RING" into the Play store. My experience was:

    1. Downloaded NFC Unlock. Got it to read my ring, wants to name it, OK. Then it asks for my login info. What login info? My Google info? It doesn't say. Create a PIN code? I already have a phone unlock code, why do I need a PIN code? Am I replacing my phone's password with this PIN code? My workplace has security requirements on my phone's unlocking, is this going to run afoul of that? What's going on?

    2. Check the website. There's no "Support" link. Everything is geared towards sales. A "Received your ring? Click here!" link would be awesome. The "FAQs" link takes me to FAQs geared to selling me on the ring, as opposed to helping me with my ring.

    3. Discover, I forget how, that ring unlock accounts are created in a separate app. Why do I need a separate app? I got this thing to unlock my phone. Android 5.0 appears to be able to let me do that, but it doesn't work well. So I'm grudgingly installing 3rd party software, to see if that helps. I got the "Unlock" app because that's what I want this to do, but that won't work unless I download a second app to make an account?

    4. Control app mentions nothing about unlocking phones with the ring. It creates an account, and offers to do things like open Twitter or something... it's annoying. I create the ring account.

    5. Open the unlock app, press the ring against the phone, get an "invalid credentials" error. What? Apparently my earlier setup of the app resulted in some creation of some credentials, but I don't know what those would be. I decide to delete the app and reload it. Now I go through setup, create a PIN, enter my new account, and now it works.

    6. I'm presented with configuration options, and it warns me about running nfc lock without also running the OS lock screen... I thought that's what this was supposed to do, to replace the standard lock screen with the nfc ring lock screen. Am I about to do something terrible? Sure feels like it. I'm wondering if I've made my unlocking of my phone longer and more annoying, instead of smoother and hassle-free.

    7. I visit the website again, check the blog. No posts on "Help setting up your new ring". There's a Tasker setup tutorial, but nothing for first-time setup that I see. No forum post that seems like it will help. So I decide to post some feedback.

    8. Discover the account I created for my ring is not in any way a website account. Create a forum account to make this post.

    9. Visit the store to check things out, discover that the forum account is not a general nfcring.com account: I don't have a store account.

    10. Navigating around the website is a nightmare. The header on every page is inconsistent: links are missing from various pages. Click the blog link and now you're on the blog: there's no link back to the home page (the NFCRING logo just refreshes the blog page). Home page doesn't have standard links at the top, but the store does. Footer on every page is different, with no standard links there, either. I'm looking for help, and your site makes it a nightmare. Finding the forums was a happy accident. Do you realize how terrible this is?

    On the whole, everything about this product has been unclear, unhelpful, and assumes the customer knows a great deal already. As a consumer experience, this has been just a giant train wreck. Makes me doubt my putting faith in this company, trusting you guys with anything in the way of security at all. Look to your new user experience.

    More feedback:

    1. Ring has two tags. What should I do? Is there a best practice for this? Does naming the ring actually name a tag on the ring? Do I need to go through the whole unlock setup again for both tags? What do the folks who made this thing recommend? Maybe the app could tell me as I set things up. Maybe it could have a wizard to help me out.

  • NFC Ring Team

    All very useful feedback, things we will get right onto sorting! Thanks!


  • Community Helper

    Point 7 - https://forum.nfcring.com/topic/288/nfc-ring-unlock-app-video-tutorial/3 and https://forum.nfcring.com/topic/274/dummies-guide-to-nfc-ring-unlock-app

    I suspect you'd be better off continuing to use it with the standard android unlock instead, and practice your read method. The NFC ring is by design quite different to a standard plastic encapsulated tag and reads and behaves differently.
    What device are you using it with?



  • I use an LG G3. When it reads, it reads quickly and easily. When it doesn't read, it absolutely doesn't read. No case on the phone, ring is twisted on my finger to have the tag oriented to the phone. I can bang the ring against the phone all I want, it won't read.

    It generally reads for a while after I've already unlocked the phone once with a password.


  • Community Helper

    You don't "bang" tags against the reader device to make them read, what makes them read is moving the tag through the rf field generated by the reader. If you do it in the wrong place or in the wrong way then you can bang it around all you like and it won't do more than bruise the phone.

    Here's a post with John's sweet spot finding video: https://forum.nfcring.com/topic/46/john-mclear-s-tutorial-how-to-find-your-sweet-spot
    I've also made numerous posts on how to find your sweet spot.

    As a general rule, if your ring reads at all then everything is fine and it's just the method that needs tweaking.



  • @Harry-Teasley

    I can bang the ring against the phone all I want, it won't read.

    don't bang it, you have to hold it on the right spot for a second, then it will work much better.

    It takes a moment to power up the chip and read the info on the chip.

    Cheers Jason


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.