Android Lollipop Trusted Device + NFC Ring = perfect



  • I have this issue as well. Is there any benefit to us posting to issue 79928 to say "me too"



  • @wlraider70 said:

    I have this issue as well. Is there any benefit to us posting to issue 79928 to say "me too"

    OF course, the more people that google can see that have the issue, across the most variety of devices will prove to google that its a big problem and its their code, nothing that another vendor has done.

    Please report your "Me Too" and hopefully we will get a more prompt fix.



  • @johnyma22 - any response from your contact in google? The google code bug post is still listed as priority "small" and still doesn't have any kind of response from google. I kind of feel like we will be here a year from now still posting "hey any update?" and still unable to use the ring.

    Also, lol @ the title of this thread. "perfect" is not normally a word I use for "completely broken feature"


  • NFC Ring Team

    @jarmer I can't say officially what the response from Google is as the response is not coming from Google's PR team or some such and I don't want to break my relationship or disrespect anyone..

    Basically Google's engineers need consistent steps to replicate the bug for them to elevate the priority of the issue. So let's try help them get that so we can get this sorted!

    J



  • @johnyma22 said:

    @jarmer I can't say officially what the response from Google is as the response is not coming from Google's PR team or some such and I don't want to break my relationship or disrespect anyone..

    Basically Google's engineers need consistent steps to replicate the bug for them to elevate the priority of the issue. So let's try help them get that so we can get this sorted!

    J

    That's a tough one, although it happens regularly. It doesn't happen "every single time"



  • As a temporary workaround, I modified the NFCLockScreenOff Xposed module to work on Marshmallow. I have it set up to enable NFC polling when the screen is on but locked.

    http://forum.xda-developers.com/showpost.php?p=64611507&postcount=667

    It also lets you silence NFC sounds.

    I have been using this for over 3 weeks now and I haven't reproduced the bug in all this time. The downside is that it needs root and Xposed Framework.



  • @jasok2 said:

    @johnyma22 said:

    @jarmer I can't say officially what the response from Google is as the response is not coming from Google's PR team or some such and I don't want to break my relationship or disrespect anyone..

    Basically Google's engineers need consistent steps to replicate the bug for them to elevate the priority of the issue. So let's try help them get that so we can get this sorted!

    J

    That's a tough one, although it happens regularly. It doesn't happen "every single time"

    In that post there are error logs posted, exact steps duplicated, and even a video posted by a user showing exactly what's happening. I'm not sure how much more detailed we can even get. This just seems to be completely ignored by google. There are lots of "hey google, what's up?" with no response.

    @Nephiel hmmm that's awesome! Thanks very much for posting. I do have root, but, I really don't want to disrupt the normal battery features of Marshmallow, so I will hold off for now and just hope for the best with an official patch.



  • If by "disrupt normal battery features" you mean consuming more battery, that is in fact is one of the reasons I removed the option to enable NFC on when the screen is off. As it is now, the module can only enable NFC when the screen turns on, which is what the Smart Lock feature should be doing anyway.



  • I recently bought a nfc ring because of lollipops native support for nfc in the smart lock function.
    I stumbled across this thread and read the bug post on google. According to the link posted in the bug file, it seems to be a wanted feature to switch off the lock functionality. Take a look at this: http://forums.androidcentral.com/android-5-0-lollipop/532617-smart-lock-phone-locked-after-4-hours-inactivity.html. Seems to be as intended to deactivate this feature after 4 hours.
    I'll see if the can be 'workarounded' with the xposed module, too. Nephiel only mentioned the marshmellow behaviour.
    Would it differ if one uses the nfc ring app? Is the nfc ring app less secure than the native android smart unlock feature?
    Thanx in advance.



  • No, the 4-hour timeout is a different behaviour (and intended, it seems). That is, the Smart Lock feature disabling itself after 4 hours of inactivity. I think it takes longer than that.

    On the other hand, the bug seems to cause the NFC radio to stop polling for tags after locking. So even though Smart Lock is enabled, it can't read them.

    I've had the bug multiple times in less than an hour so it is definitely not the same as the stated timeout.

    In any case, the Xposed module does nothing about the timeout. I still have to draw the pattern once every morning. But not during the day after that. Sometimes, it takes a bit longer to read the ring and the screen turns off before unlocking, but then it usually reads right away after turning on again, so it works for me. YMMV.



  • @Nephiel said:

    I still have to draw the pattern once every morning. But not during the day after that. Sometimes, it takes a bit longer to read the ring and the screen turns off before unlocking, but then it usually reads right away after turning on again, so it works for me. YMMV.

    Yeah, and this annoyes me. I want to use a hard password i only have to use in case of lost nfcs. This password would not be memorizable then. But if i have to input my pw every morning i have to choose a very soft one. Thats not what i wanted. I - of course - dont blame you or jonny for this, only google.



  • So interestingly, since my replacement ring this has stopped happening to me, its currently worked 100% of the time for the last few days.

    I don't see how that could be but there it is. Maybe it is just because I removed all the old trusted devices and added new ones since the last phone update or maybe it the ring.

    Maybe some of you guys could try removing all of your trusted devices and adding them again, see if that helps.



  • Removed all, then only added ks2016 ring same effect - works well for a short period then fails to play nicely with other there after.



  • @jasok2 said:

    So interestingly, since my replacement ring this has stopped happening to me, its currently worked 100% of the time for the last few days.

    I don't see how that could be but there it is. Maybe it is just because I removed all the old trusted devices and added new ones since the last phone update or maybe it the ring.

    Maybe some of you guys could try removing all of your trusted devices and adding them again, see if that helps.

    Since the last phone update...Whats your current android version?



  • @ave2000 said:

    Since the last phone update...Whats your current android version?

    6.0.1 patch level 1 January 2016

    EDIT - and just as I wrote that 1 Feburary 2016 patch came through, so I will keep you all posted on that too.



  • @jasok2 Its now happened just once with the 1 Feburary update.



  • This post is deleted!