Help: locked out completly by NFC Ring Unlock

  • I had this same thing happen when I tried to disable/enable using the widget (which force closes the app). The result was that it would not recognize the ring and I could not gain access with my Google account. Luckily, I created a backup NFC tag that did unlock the app. I have since set a pin in case this happens again. I have no clue what happened. When I went to reprogram the ring, it said it was already added. I had to delete it and re add it to get it to work again. This seems like a pretty bad bug.

  • Community Helper

    @SvanGool I've got a Z2 tablet here, not rooted. Attempting to duplicate what happened to you by turning on flight mode then locking the device does stop authentication via google servers but you're still able to either swipe down from the top for menus or hold the power button as though you were turning off the device and then the menu appears which allows you to turn off flight mode and re-enable the radios.
    I haven't actually been able to find any setting or combination of settings that will stop that menu from appearing when the power button is held... ?

    @Dolfans311 same thing with your issue, I've tried duplicating it on a couple of devices and can't, are you sure something else didn't happen to stop your ring working? If the backup tag successfully unlocked the device then I can't see how it's a bug in the unlock app, especially if the ring was already added.
    Did you perhaps overwrite the contents of the ring?

  • @lokki it must be handled differently on different phones. On my nexus 5 if the unlock screen is showing you can't open notifications pull down, and power button menu will only appear below the lock screen.

  • Community Helper

    Ah ok, that's interesting @shama - I'd have thought that the Z2 Tablet would at least have been the same, they're only new and should all be running the same android version so far. My Xperia M shows the power button menu too, as does my cranky HTC OneX when the screen works.

  • Community Helper

    you may need to swipe down twice since the unlock app runs in full screen mode. so swipe down one to get the status bar displayed and then again to get the notifications / quick settings menue
    this should work

  • @lokki I am running Cyanogenmod on a Verizon HTC One. The widget toggle has never worked for me and caused the issue described previously twice (then I quit using the widget). Everything seems to work fine as long as I enable/disable in the app.
    I don't know if it's related to prior issues, but the side of my ring I use to unlock now appears to be dead. It is no longer recognized by the unlock app and I can not rewrite it in the app. Is there anything else I should try before I return it (or just wait for my voucher since this is a temporary ring)? Assuming it is dead, should I return it so it can be inspected to determine what failed to help future builds?

  • Community Helper

    please try scanning it without any app open and the device unlocked. if you hear the "NFC connection established" sound the inlay should be fine.

  • Community Helper

    @Dolfans311 Ah, right. that would have glitched something by force closing the app, mate. That's on the list of not recommended things to do.
    Are you able to read the dead side of the ring with anything else like NXP tagwriter? If you can determine that side is truly dead then contact and advise them that it's not working and request a return.

  • I had a problem with my NFC Unlock app not letting me "in" after switching to Airplane mode.
    On Airplane Mode that NFC transmitter is as disabled as is any internetconnection so neither NFC unlock nor Gmail unlock will work.

    I have read that some saw now other way then factory resetting their device.
    I was also going to do that when I stumbled upon a promising item in the Recover Menu: "Wipe Cache"

    So I though what the heck, before factory resetting the device I might as will try wiping that damn cache and see what happens.
    After wiping the cache, I booted and android went through all those apps, and then showed the unlocked launcher for long enough to switch off the airplane mode, just before the unlock app was loaded and immediately locked the screen again. Only this time I could unlock it normally :P

  • Community Helper

    @svh nice one. I hope you've set a PIN in the unlock app now for emergency access!