Having issues with my ring

  • Hi,

    I am having issues with my ring.

    I have had the ring for little over a week now and have not been able to get the ring to work. I am using a Samsung S4 with a lemon battery which is NFC capable.

    I have also swapped out the lemon battery for the stock battery and still not having any luck. the extra tags that came with my NFC ring are working with no issues. i have been reading the forum and also watched the video that John posted about finding the sweet spot and still have not had any luck. i am not able to read or write to both sides of the ring, i have rotated the ring while trying to read/write to the ring, i have taken the case off.

    The ring i ordered was the Normal (Classic) Ring in Black Plated Metal with a Black top inlay cover and a Black bottom inlay cover in USA Ring Size 9.5. any help would be much appreciated.

  • any help would be great, I'm still having issues.

  • Community Helper

    I have no S4 and can't help you with that side but have you tried the ring with some different phones? e.g. on of a friend or so.

  • NFC Ring Team

    Have you tried using the NFC Ring Control app so you can see where the sweet spot is?

  • I can test with a note 3 and as soon as i do i will report back with what happens.

    Also yes i have the NFC Ring control app, and it will not let me read or write to the ring. the app is working with the other tags i received with my ring. i think i got one of the alfa tags, and also sticker tag. after reading or writing to the other tags i can see the sweet spot heat map but even using the same sweet spots shown i'm still not able to read/write to the ring.

  • Community Helper

    It might sound silly, but you do have NFC turned on, and S-Beam turned off on your phone?
    Can you test with a normal tag to make sure your phone is in the right state to read NFC?

  • Hi, Yes NFC is turned on and S-beam turned off, i can read and write to other tags with no problems, but not the ring. The same is for the note 3, NFC on, S-beam off, can read and write to normal tags, But not the ring, and im using the NFC ring control app on both devices.

  • Community Helper

    Ah, that's no good that you're getting the same result with both phones. That said, both phones are known to be difficult in some circumstances.
    If you've tried the various methods to help improve ring reading like rolling through potential sweet spots and checking both horizontal and vertical orientation then it may be time to contact support@nfcring.com and explain what's happening. Quote this thread so that they can follow up the issues if necessary, and explain which phones, which ring and whats happening.

  • Yes i have tired various orientations, an still no results, i will get back in touch with support on this matter.

  • Community Helper

    Good deal, let us know how you go.