Any clue

  • I've tried hard to register my ring without hope at all. Struggling to find my sweet spot is the only message I always getting.
    HUAWEI mate 8 is my device.

    Any clue?

  • NFC Ring Team

    Registration should be disabled / not required any more.. Try update your app? :)

  • Thank you.
    My device HUAWEI Mate 8 couldn't recognize my ring. I've tried every thing without hope.

    Please help SOS.

  • Community Helper

    Hi, which ring do you have, is your NFC turned on in your device and are you carefully, slowly running the ring along/over/around the back of the device to try for a read?
    Sometimes it can be a little fiddly to get the hang of it for a start.

  • Thank you very much for your assistance.
    I identified my sweet spot and the ring finally connected with my mate 8, however, it cannot accept transferring my data, it said "Unable to write to your NFC, tag is read only".

    How to solve this issue?

  • Community Helper

    If you can, download "NXP TagWriter" from the play store, and see if you can read/write the ring with that. You may possibly need to format the tag.
    Is this happening with both sides of the ring?

  • @Lokki Yes this happened with both sides. How to format the tag?

  • I've tried to format the tag but I got "Format Failed, IO Failure" message.

    How to correct this failure?

  • Why my ring cannot accepting to write data?. A message said (tag for reading only) every time I tried to write my data on the ring.

  • Community Helper

    The format might fail if you're not holding the ring in the right spot for long enough, you're going to need to be patient and try a bit more, perhaps while you're doing this it might be easier to take the ring off your finger and hold it directly against the phone in the sweet spot.

  • @Lokki Thank you very much for your concern and prompt respond. The tag on the soft side (black) of the ring has been formatted (quick format method), but not accepting full formatting; furthermore, the other side of the ring (carbon fiber) has never accepting formatting due to partial protection. I have tried to remove the protection, however, it wont be removed on this tag (carbon fiber) side, but not on the other side (black). This problem eliminating writing on both sides of the ring. I would like to add that this problem occurred once I used the app to lock the phone, but even after unlocking, the issue still existing.

    Thank you @Lokki for your assistance.

  • Whenever I tried to write it said "Read only cannot write", that's including booth sides (tags).

  • Community Helper

    Hi Az, if the ring has arrived in your hands with write protected tags then open a dialogue with