Elechouse PN532 NFC Module V3 for Arduino etc.

  • ive recently gotten quite interested in the mysensors opensource automation gear at the moment...

    am thinking about intergrating some of their work into this as well....

    basicly rfm 838 mhz radio transfer tech....add in a remote starter type thing....

  • Community Helper

    All good then! There's nothing more embarassing than coasting across three lanes of traffic then pulling your steering column apart to hotwire the car... * cough *

    So what kind of vehicle are you putting this all in?

  • 1996 mitsubishi mirage....pretty tame car, but i figure the wiring will be much easier that way.....
    still gotta workout how to diable the colum lock

  • Community Helper

    Not bad, it should do the trick. I actually just removed the steering lock in the skyline to do this, I was looking for an electrically actuated steering lock off a late model car to replace it but never quite got there.

  • from my copious googleing it looks like its just a spring i need to remove...which shouldnt be hard....

    want to leave the key in the car for a month or so.......JUSTIN CASE

  • Community Helper

    Haha, yeah. I compensated for the removal by installing a combination gps tracker and killswitch.

  • so both good news and bad....got the device in and mounted....
    but burnt out my imoboliser....didnt even know i had one.....so trip to the auto elec's tomorrow

  • Community Helper

    @MarkGabb urk. How'd you manage that?

  • well im not sure.......but i have a theory.... there is an Nti jumpstart plug on my cylinder, cant start car unless keys are in ignition.... so i bridged the wires.....

    have a feeling it may have a resistive circuit instead of a strait switch...

  • basicly the most icdo know is that it did work, then suddenly which trying to start it now cranks over but wont latch on....

  • @Lokki I bought one of these for mi Raspberry pi 2. I would like to know how to conect to it.
    What would be an easy way? Perhaps with a TTL to USB cable directly to a usb raspberry port?
    I am newbie :D

  • Community Helper

    @Javier, sorry connect which to the Raspberry Pi? They have a pin header which provides GPIO access for things like I2C interface (for a PN532 reader module) and programmable pins that will allow you to control relays to affect real-world parts of your vehicle.
    I don't particular like Raspberry Pi and so I don't have a huge amount of experience using them, but that's the basics right there.
    But no. Probably not TTL converters, and probably not via a USB port.

  • Hi all,

    I've ordered the same module and fighting with that for more that a week, but without any success. I've the version 3 of the NFC module and WDLduino UNO. I've switched the NFC module to use I2C (switch 1 on, switch 2 off). The problem is, that the sample code does not go through the initialization state, so the loop never starts. Also the initialization does not write that the board is not found, it only hangs. What is also interesting, that the power light on the NFC module is also off.
    I've 2 ARDUINOs (the same type) and also two NFC modules (ordered from different stores), but both have the same issue. Do you have any idea, what could be the problem or what else can I check?

    Some additional notes: I've turned on the debugging on the NFC library, so I know, that the code is hanging on PN532_I2C::wakeup, the _wire->endTransmission(); never comes back (PN532_I2C.cpp).


    Any idea or help would be appreciated.

  • Community Helper

    Hi @Pingi , what you've got there so far all looks correct physically, but the fact that the power light isn't coming on is interesting - it definitely should when power is connected, regardless of what is running on the code side of things.
    You might need to double check all that, possibly use a multimeter to make sure that you're actually getting power at the reader unit.

  • Hey guys, need your help with similar problem as discussed earlier. My PN532 NFC module V3 won't work in I2C mode. I've switched the switch to correct possition, I've tried with both 3.3V and 5V. The module is powered (LED is on). When everything is connected, the COMM manager only says "Hello" and nothing else. If I disconnect one of the cables, it will say "Didn't find PN53x board". I have changed the initial "elif" statement, as written in the handbook, so it will work in I2C mode. However, I still can't get past the "Hello".
    Any suggestions?
    Many thanks ;)

  • I have the same issue. I am trying to conect a elechouse PN532 NFC module V3 to arduino nano and nothing. Same problem. Only says "hello".

  • Community Helper

    What code and libraries are you guys using to try to make it happen?

  • Hi @Lokki, thanks for you answer, I've tried a lot of different ways, how to power the NFC board, but the power led is still off. So, I've decided to open a complain at the store where I've bought the NFC shield, as in my opinion, the power led should at least work, otherwise the shield is non-functional.

  • Community Helper

    @Pingi No worries. With mine, the power led is on when power is applied, no matter whether data is hooked up or not.

  • @Lokki Hey, thanks for getting back to me. I'm using the recomended library by Elechouse (on github under elechouse/PN532) together with included NDEF library. I also tried Don's NDEF library, but I think they're the same.