Problem Phones


  • Community Helper

    This is a brief list of 'Problem Devices' which seem to be consistently giving people trouble with Classic band NFC Rings.
    They appear to be more suited to Alpha rings, though in some cases if there are extra issues with the NFC setup in the device the Alpha may also be problematic.

    Galaxy Note 2
    Galaxy Note 3
    Galaxy S5
    Galaxy S4
    Galaxy S3
    LG G2
    Nexus 4
    Nexus 7 (2012)
    HTC Droid DNA
    Blackberry devices


  • NFC Ring Team

    Note 3?

    BlackBerry devices also have a pretty substandard performance



  • Hi, Just got my awesome (normal) ring - amazing build quality, but it is a no go with my Galaxy S4.
    Unfortunately I did not see this thread before ordering.... only looked up as part of my troubleshooting.

    It seems that the antenna on the ring is just not strong enough to pick up the signal on my phone.

    I started trying to use with my Lloyd Flex case on the phone (http://www.androidcentral.com/deal-day-lloyd-flex-case-samsung-galaxy-s4) with ZERO luck in activating NFC. It just cannot penetrate the case.

    I then moved to trying without the case (bare S4). Even then i have around 50% or maybe less luck in activating NFC. I also have a hard time consistently finding the best activation (sweet) spot. it is super tricky as it seems that the ring is just not strong enough.

    I took one step further and removed the back cover of the phone. Then i had a bit more luck, but still far from perfect. Obviously though i cannot use the phone without a back cover.

    I have just read that there were issues in the past but have been resolved. This post points to using the Alpha ring versus the normal.

    I am very excited at using the ring, but am obviously looking for a solution that works.

    I am will to try out things as you may advise.
    Hoping you can solve the issues.... David


  • Community Helper

    Hi @David223, There are S4s that work without a hitch, but there are also quite a few that just seem to have trouble doing anything. As a f'rinstance John's QA team test against an S4 before allowing rings to pass inspection.
    Just to clear up a basic misunderstanding here, it's the phone that's not strong enough - the ring doesn't actually output a signal. So at the root of the issue is your phone in some manner. This could be either dirty contacts on the NFC antenna, it's on the battery and so any jolting or bumping or even trace amounts of moisture can affect the contacts and lessen the power which actually gets to the NFC antenna.

    By order of personal difficulty:

    The Alpha can sometimes provide a workaround for this, by dint of having a larger antenna to 'catch' in the weaker RF field. So that's an option, contacting support to request one.

    Another option could be having your phone checked out by a repair service - but they're just as likely to claim there's nothing wrong with the NFC because frankly, it's a lot of messing around to fix it. And far easier to replace the whole phone. But cheaper to just tell you there's no issue after testing with a mifare card. You may get a result if you are really insistent.

    Your last option is to practice and practice and practice - the fact that it reads sometimes means that if you can practice until you consistently hit exactly that spot in exactly that manner until you get a good read every time you intend to.
    I don't think many people believe me but it really is like whistling or riding a bike. You can't just do these things straight away, you have to work at them. Only then do they become easy once they're muscle memory.

    In summary there is no real easy answer, especially if you want to keep the ring you have. But if you work at it then you may find that it becomes easier after it becomes most frustrating.



  • Oneplus one doesnt work, might need an alpha to work, but ring doesn't pick up anything


  • NFC Ring Team

    @angus Information here, peep:

    https://twitter.com/Anthodev/status/539840390288138240

    "Got my Alpha @NfcRing today, it works through the @oneplus case, i'm really happy \o/"

    So yeah maybe oneplus needs an alpha?



  • Angus it worked for me with a non-Alpha ring



  • Well my Note 3 was working swimmignly for a while after set up yesterday and now nope.
    Sprint touch app isn't working, never knew there was such an app, but whatever option in the nfc ring software that brought it up, hasn't worked even before I finished set up, and was not working when the unlock on the ring was functional.


Log in to reply
 

Looks like your connection to NFC Ring Forum was lost, please wait while we try to reconnect.